use strict;
my $str = '00:59am';
my $regex = qr/(([0][1-9]|[1][0-2]):([0-5][0-9])([p][m]))|(([0][0-9]|[1][01]):([0-5][0-9])([a][m]))/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}