package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(hello(\w| )+you)`)
var str = `hello my friend, i want to say hello to all of you`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}