$re = '/(hello(\w| )+you)/m';
$str = 'hello my friend, i want to say hello to all of you';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);