const regex = /\b(?!(?:[^\d\s]*\d){2})[\w@#$]+\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?!(?:[^\\d\\s]*\\d){2})[\\w@#$]+\\b', 'gm')
const str = `ab3c
a@bc
a@1c
4
a2
Test12
12
1test3
This is a test 4 test 1test2 and 2test and test4test and te12test3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}