$re = '/\b(?!(?:[^\d\s]*\d){2})[\w@#$]+\b/m';
$str = 'ab3c
a@bc
a@1c
4
a2
Test12
12
1test3
This is a test 4 test 1test2 and 2test and test4test and te12test3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);