$re = '/<\/?(\w+)((\s+\w+(\s*=\s*(?:".*?"|\'.*?\'|[\^\'">\s]+))?)+\s*|\s*)\/?>/m';
$str = 'I want to replace any html tags, ignoring <span id="ID" class="class">text inside</span> the tags.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);