re = /<\/?(\w+)((\s+\w+(\s*=\s*(?:".*?"|'.*?'|[\^'">\s]+))?)+\s*|\s*)\/?>/m
str = 'I want to replace any html tags, ignoring <span id="ID" class="class">text inside</span> the tags.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end