import re
regex = re.compile(r"<h2>\K[^<]+", flags=re.MULTILINE)
test_str = ("<span><h2>Category 1</h2>\n"
"<p><strong><u>Entry 1</u></strong></p>\n"
"<ul><li>Some Data</li></ul>\n"
"<h2>Category 2</h2>\n"
"<p><strong><u>Entry 2</span>\n"
"<ul><li>Some Data</li></ul>\n"
"</span>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")