re = /<h2>\K[^<]+/m
str = '<span><h2>Category 1</h2>
<p><strong><u>Entry 1</u></strong></p>
<ul><li>Some Data</li></ul>
<h2>Category 2</h2>
<p><strong><u>Entry 2</span>
<ul><li>Some Data</li></ul>
</span>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end