#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)<h2>[^<]+<\/h2>(.+?<\/ul>)"
Local $sString = "<span><h2>Category 1</h2>" & @CRLF & _
"<p><strong><u>Entry 1</u></strong></p>" & @CRLF & _
"<ul><li>Some Data</li></ul>" & @CRLF & _
"<h2>Category 2</h2>" & @CRLF & _
"<p><strong><u>Entry 2</span>" & @CRLF & _
"<ul><li>Some Data</li></ul>" & @CRLF & _
"</span>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")