import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<h2>[^<]+<\\/h2>(.+?<\\/ul>)";
final String string = "<span><h2>Category 1</h2>\n"
+ "<p><strong><u>Entry 1</u></strong></p>\n"
+ "<ul><li>Some Data</li></ul>\n"
+ "<h2>Category 2</h2>\n"
+ "<p><strong><u>Entry 2</span>\n"
+ "<ul><li>Some Data</li></ul>\n"
+ "</span>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}