$re = '/^(?=.*[A-Z].*[A-Z])(?=.*[!@#$&*_-])(?=.*[0-9].*[0-9])(?=.*[a-z].*[a-z].*[a-z]).{8}$/';
$str = 'AA11@aaa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);