re = /^(?=.*[A-Z].*[A-Z])(?=.*[!@#$&*_-])(?=.*[0-9].*[0-9])(?=.*[a-z].*[a-z].*[a-z]).{8}$/
str = 'AA11@aaa'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end