package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+\D+(\d+\s*\w+)`)
var str = `1 - hello world 1234 abc 5678 def`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}