package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[A-Z][a-z]*(?:_?[A-Z][a-z]*)*\b`)
var str = `snake_case and PascalCase naming conventions. So, declaring a class its name must match the following format strictly: Pascal_Snake, Pascal_Snake_Pascal_Etc, OnlyPascal, Pascal.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}