re = /\b[A-Z][a-z]*(?:_?[A-Z][a-z]*)*\b/m
str = 'snake_case and PascalCase naming conventions. So, declaring a class its name must match the following format strictly: Pascal_Snake, Pascal_Snake_Pascal_Etc, OnlyPascal, Pascal.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end