using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\(|\{|\[)(.+)(?:\)|\}|\])";
string input = @"(1{2(3)})
{content{deeper content{deepest content}}}
[some text[more text]] ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}