$re = '/(?:\(|\{|\[)(.+)(?:\)|\}|\])/';
$str = '(1{2(3)})
{content{deeper content{deepest content}}}
[some text[more text]] ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);