import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^User name:)\\s*(\\S.+)$";
final String string = "Action: NEW\n\n"
+ "User name: Matthew Thomas\n"
+ "Job title: Dealer Account Manager\n"
+ "Direct report: Craig Carlson\n"
+ "Department: Dealer Account Management\n"
+ "Location: Milton, QLD\n"
+ "Employment type: Permanent Full Time\n"
+ "Start date: 15/07/2013\n"
+ "Finish date:\n\n\n"
+ "__________________________________________\n"
+ "Decision Point 3\n"
+ "--------------\n"
+ "Read Only";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}