use strict;
my $str = 'Action: NEW
User name: Matthew Thomas
Job title: Dealer Account Manager
Direct report: Craig Carlson
Department: Dealer Account Management
Location: Milton, QLD
Employment type: Permanent Full Time
Start date: 15/07/2013
Finish date:
__________________________________________
Decision Point 3
--------------
Read Only';
my $regex = qr/(?<=^User name:)\s*(\S.+)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}