$re = '/<ForeignTable(.|\n|\r\n)*?<\/ForeignTable>/';
$str = 'skjghkfbhkljfbvg
gfsdjhgisufgh
foreign
<<<>>>>>
<ForeignTable Name="JobPlan" Alias="FK0024">
<Fields>
<Field Name="JpDescr" Alias="F24000" />
</Fields>
<MaskInfo Rights="Add" AddContext="1">
<ContextStatus Context="1" Status="0" Update="True" />
</MaskInfo>
</ForeignTable>
fghisujfh
fsdoguhksujdfhg
isdjfogihodfuiyfkg
alias
add
table
<ForeignTable jhkjh
skjhgksjhfg
skdfjghkjsdfhg
</ForeignTable>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);