// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<ForeignTable(.|\n|\r\n)*?<\/ForeignTable>").unwrap();
let string = "skjghkfbhkljfbvg
gfsdjhgisufgh
foreign
<<<>>>>>
<ForeignTable Name=\"JobPlan\" Alias=\"FK0024\">
<Fields>
<Field Name=\"JpDescr\" Alias=\"F24000\" />
</Fields>
<MaskInfo Rights=\"Add\" AddContext=\"1\">
<ContextStatus Context=\"1\" Status=\"0\" Update=\"True\" />
</MaskInfo>
</ForeignTable>
fghisujfh
fsdoguhksujdfhg
isdjfogihodfuiyfkg
alias
add
table
<ForeignTable jhkjh
skjhgksjhfg
skdfjghkjsdfhg
</ForeignTable>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}