import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\'|\"\")My-Text(\\'|\"\"):.*?";
final String string = "{''Remote-Control': 'no-control, must', 'My-Text': \"input-src 'something' 'perfect-out' 'perfect-in' *.exampl.com\", 'Some': '1; 'Encoding': 'gzip'}\n"
+ "{''Remote-Control': 'no-control, must', 'My-Text': \"input-src *\", 'Some': '1; 'Encoding': 'gzip'}\n"
+ "{''Remote-Control': 'no-control, must', 'My-Text': \"output-src *.exampl.com\", 'Some': '1; 'Encoding': 'gzip'}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}