$re = '/([a-z]|[A-z]){3,5}#(H|F|Z|Q)([1-2]|[3-4]|[5-6]|[7-8])/';
$str = 'aaa#H';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);