import re
regex = re.compile(r"([a-z]|[A-z]){3,5}#(H|F|Z|Q)([1-2]|[3-4]|[5-6]|[7-8])")
test_str = "aaa#H"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")