import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\+62|08)[\\s._-]?(?=[\\d\\s._-]{8})\\d+(?:[\\s._-]\\d+)*\\b";
final String string = "0823 2371 2318\n"
+ "+62812 2712 2819\n"
+ "Whatsapp :+62 822-5286-0991";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}