$re = '/(?:\+62|08)[\s._-]?(?=[\d\s._-]{8})\d+(?:[\s._-]\d+)*\b/m';
$str = '0823 2371 2318
+62812 2712 2819
Whatsapp :+62 822-5286-0991';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);