using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^var json = \K{.*?}(?=;)";
string input = @"Survey
.StylesManager
.applyTheme(""default"");
var json = {
questions: [
{
name: ""name"",
type: ""text"",
title: ""Please enter your name:"",
placeHolder: ""Jon Snow"",
isRequired: true
}, {
name: ""birthdate"",
type: ""text"",
inputType: ""date"",
title: ""Your birthdate:"",
isRequired: true
}, {
name: ""color"",
type: ""text"",
inputType: ""color"",
title: ""Your favorite color:""
}, {
name: ""email"",
type: ""text"",
inputType: ""email"",
title: ""Your e-mail:"",
placeHolder: ""jon.snow@nightwatch.org"",
isRequired: true,
validators: [
{
type: ""email""
}
]
}
]
};
window.survey = new Survey.Model(json);
survey
.onComplete
.add(function (result) {
document
.querySelector('#surveyResult')
.innerHTML = ""result: "" + JSON.stringify(result.data);
});
$(""#surveyElement"").Survey({model: survey});";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}