# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^var json = \K{.*?}(?=;)"
test_str = ("Survey\n"
" .StylesManager\n"
" .applyTheme(\"default\");\n\n"
"var json = {\n"
" questions: [\n"
" {\n"
" name: \"name\",\n"
" type: \"text\",\n"
" title: \"Please enter your name:\",\n"
" placeHolder: \"Jon Snow\",\n"
" isRequired: true\n"
" }, {\n"
" name: \"birthdate\",\n"
" type: \"text\",\n"
" inputType: \"date\",\n"
" title: \"Your birthdate:\",\n"
" isRequired: true\n"
" }, {\n"
" name: \"color\",\n"
" type: \"text\",\n"
" inputType: \"color\",\n"
" title: \"Your favorite color:\"\n"
" }, {\n"
" name: \"email\",\n"
" type: \"text\",\n"
" inputType: \"email\",\n"
" title: \"Your e-mail:\",\n"
" placeHolder: \"jon.snow@nightwatch.org\",\n"
" isRequired: true,\n"
" validators: [\n"
" {\n"
" type: \"email\"\n"
" }\n"
" ]\n"
" }\n"
" ]\n"
"};\n\n"
"window.survey = new Survey.Model(json);\n\n"
"survey\n"
" .onComplete\n"
" .add(function (result) {\n"
" document\n"
" .querySelector('#surveyResult')\n"
" .innerHTML = \"result: \" + JSON.stringify(result.data);\n"
" });\n\n"
"$(\"#surveyElement\").Survey({model: survey});")
matches = re.search(regex, test_str, re.MULTILINE | re.DOTALL)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.