# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\s*\K\w+/"\0"/mg;t' <<< "{
questions: [
{
name: \"name\",
type: \"text\",
title: \"Please enter your name:\",
placeHolder: \"Jon Snow\",
isRequired: true
}, {
name: \"birthdate\",
type: \"text\",
inputType: \"date\",
title: \"Your birthdate:\",
isRequired: true
}, {
name: \"color\",
type: \"text\",
inputType: \"color\",
title: \"Your favorite color:\"
}, {
name: \"email\",
type: \"text\",
inputType: \"email\",
title: \"Your e-mail:\",
placeHolder: \"jon.snow@nightwatch.org\",
isRequired: true,
validators: [
{
type: \"email\"
}
]
}
]
}"