using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*\K\w+";
string substitution = @"""\0""";
string input = @"{
questions: [
{
name: ""name"",
type: ""text"",
title: ""Please enter your name:"",
placeHolder: ""Jon Snow"",
isRequired: true
}, {
name: ""birthdate"",
type: ""text"",
inputType: ""date"",
title: ""Your birthdate:"",
isRequired: true
}, {
name: ""color"",
type: ""text"",
inputType: ""color"",
title: ""Your favorite color:""
}, {
name: ""email"",
type: ""text"",
inputType: ""email"",
title: ""Your e-mail:"",
placeHolder: ""jon.snow@nightwatch.org"",
isRequired: true,
validators: [
{
type: ""email""
}
]
}
]
}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}