using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a.*\[monitory\].*href=[""|']([http:|https:]?[\/\/]?.*?)[""|']>";
string input = @"<a [monitory] href=|http:/www.teste.com|>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}