package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*Million \(USD\)\s*$`)
var str = `2.7 Million (USD)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}