#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^(\d|\+|\(|)" & @CRLF & _
                "(\d+|xx)" & @CRLF & _
                "(xx|.)?" & @CRLF & _
                "(\d+|.)?" & @CRLF & _
                "(\))?" & @CRLF & _
                "(\d)?" & @CRLF & _
                "(\d|.)?" & @CRLF & _
                "(\))?" & @CRLF & _
                ".+"
Local $sString = "9876-5432" & @CRLF & _
                "98765-4321" & @CRLF & _
                "11 9876-5432" & @CRLF & _
                "011 9876-5432" & @CRLF & _
                "0xx11 9876-5432" & @CRLF & _
                "0xx 11 9876-5432" & @CRLF & _
                "+55 11 9876-5432" & @CRLF & _
                "+55 11 98765-4321" & @CRLF & _
                "+551198765432" & @CRLF & _
                "+5511987654321" & @CRLF & _
                "(11)9876-5432" & @CRLF & _
                "(11) 9876-5432" & @CRLF & _
                "(0xx11) 9876-5432" & @CRLF & _
                "+55 (11) 98765-4321"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
    _ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")