use strict;
my $str = '9876-5432
98765-4321
11 9876-5432
011 9876-5432
0xx11 9876-5432
0xx 11 9876-5432
+55 11 9876-5432
+55 11 98765-4321
+551198765432
+5511987654321
(11)9876-5432
(11) 9876-5432
(0xx11) 9876-5432
+55 (11) 98765-4321';
my $regex = qr/^(\d|\+|\(|)
(\d+|xx)
(xx|.)?
(\d+|.)?
(\))?
(\d)?
(\d|.)?
(\))?
.+/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}