$re = '/<link (?=[^>]*rel=\s*[\'"]stylesheet[\'"])(?![^>]*href=\s*[\'"]http)[^>]*>/i';
$str = '<link rel="stylesheet" href="http://blahblah">
<link rel="stylesheet" href="//" >
<link rel=\'stylesheet\' href=\'//\' >
<link rel=\'stylesheet" href=\'//\' >';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);