#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)(?<=\d-)(?<imagenum>\d+)\.jpg$"
Local $sString = "C2-123-1.JPG" & @CRLF & _
"C2-123-2.JPG" & @CRLF & _
"C2-123-3.JPG" & @CRLF & _
"C3-333-1.JPG" & @CRLF & _
"C3-333-2.JPG" & @CRLF & _
"C3-333-4.JPG" & @CRLF & _
"C3-333-999.JPG" & @CRLF & _
"C3-456-2.JPG" & @CRLF & _
"C3-111-2.JPG" & @CRLF & _
"C3-999-4.JPG"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")