re = /(?i)(?<=\d-)(?<imagenum>\d+)\.jpg$/m
str = 'C2-123-1.JPG
C2-123-2.JPG
C2-123-3.JPG
C3-333-1.JPG
C3-333-2.JPG
C3-333-4.JPG
C3-333-999.JPG
C3-456-2.JPG
C3-111-2.JPG
C3-999-4.JPG'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end