re = /([-a-zA-Z0-9@:%._\+~#=]{2,256}\.[a-z]{2,6})\b([-a-zA-Z0-9@:%_\+.~#?&\/=]*)/
str = 'what is <http://google.com>?
what is www.ibm.com?
are these the Droids.I.com?Lookingfor=Yes'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end