using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(.*?\)";
string input = @"stuff
stuff (single_word)
stuff (single_word) more stuff
stuff (multiple words)
stuff (words (inside (other) words) eww)
stuff (first group) stuff (second group)
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}