package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(.*?\)`)
var str = `stuff
stuff (single_word)
stuff (single_word) more stuff
stuff (multiple words)
stuff (words (inside (other) words) eww)
stuff (first group) stuff (second group)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}