using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[!@#$%^&*()\-_+=\/?.,>~\\|\[\];:""'{}])(?=\S+$).{8,}$";
string input = @"aZ1!aZ1!""'ss
at least 1 small letter
at least 1 upper case letter
minimum of 8 characters
at least 1 number
at least 1 special character";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}