package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^;]+;[^;]+;[^;]+)`)
var str = `Arruela;10;5;Porca;10;6;Parafuso;10;7`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}