$re = '/([^;]+;[^;]+;[^;]+)/m';
$str = 'Arruela;10;5;Porca;10;6;Parafuso;10;7';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);