#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?:Jan(?:uary)?|Feb(?:ruary)?|Mar(?:ch)?|Apr(?:il)?|May|Jun(?:e)?|Jul(?:y)?|Aug(?:ust)?|Sep(?:tember)?|Oct(?:ober)?|Nov(?:ember)?|Dec(?:ember)?)\ *\d+(?:[nr]d|th|st)?(?:-\d+(?:[nr]d|th|st)?)?|\d+(?:[nr]d|th|st)?(?:-\d+(?:[nr]d|th|st)?)?\ *(?:Jan(?:uary)?|Feb(?:ruary)?|Mar(?:ch)?|Apr(?:il)?|May|Jun(?:e)?|Jul(?:y)?|Aug(?:ust)?|Sep(?:tember)?|Oct(?:ober)?|Nov(?:ember)?|Dec(?:ember)?)"
Local $sString = "some garbagde . some garbagde 02 APR some garbagde" & @CRLF & _
"some garbagde . some garbagde APR 02 some garbagde " & @CRLF & _
"some garbagde . some garbagde 1st APR some garbagde" & @CRLF & _
"some garbagde . some garbagde APR 2 some garbagde" & @CRLF & _
"some garbagde . some garbagde 2nd APR some garbagde" & @CRLF & _
"some garbagde . some garbagde 2nd August some garbagde" & @CRLF & _
"some garbagde . some garbagde APR 2nd some garbagde" & @CRLF & _
"some garbagde . some garbagde 2nd April some garbagde" & @CRLF & _
"some garbagde . some garbagde April 2nd some garbagde" & @CRLF & _
"some garbagde . some garbagde APR 12th some garbagde" & @CRLF & _
"some garbagde . April 12th some garbagde" & @CRLF & _
"some garbagde . 12th April some garbagde" & @CRLF & _
"some garbagde . April 13-16 some garbagde" & @CRLF & _
"some garbagde . 13-16 April some garbagde" & @CRLF & _
"some garbagde . APR 13-16 some garbagde" & @CRLF & _
"some garbagde . 13-16 APR some garbagde" & @CRLF & _
"some garbagde . April 13th-16th some garbagde" & @CRLF & _
"some garbagde . 13th-16th April some garbagde" & @CRLF & _
"some garbagde . APR 13th-16th some garbagde" & @CRLF & _
"some garbagde . 13th-16th APR some garbagde"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")