re = /(?:Jan(?:uary)?|Feb(?:ruary)?|Mar(?:ch)?|Apr(?:il)?|May|Jun(?:e)?|Jul(?:y)?|Aug(?:ust)?|Sep(?:tember)?|Oct(?:ober)?|Nov(?:ember)?|Dec(?:ember)?)\ *\d+(?:[nr]d|th|st)?(?:-\d+(?:[nr]d|th|st)?)?|\d+(?:[nr]d|th|st)?(?:-\d+(?:[nr]d|th|st)?)?\ *(?:Jan(?:uary)?|Feb(?:ruary)?|Mar(?:ch)?|Apr(?:il)?|May|Jun(?:e)?|Jul(?:y)?|Aug(?:ust)?|Sep(?:tember)?|Oct(?:ober)?|Nov(?:ember)?|Dec(?:ember)?)/mi
str = 'some garbagde . some garbagde 02 APR some garbagde
some garbagde . some garbagde APR 02 some garbagde
some garbagde . some garbagde 1st APR some garbagde
some garbagde . some garbagde APR 2 some garbagde
some garbagde . some garbagde 2nd APR some garbagde
some garbagde . some garbagde 2nd August some garbagde
some garbagde . some garbagde APR 2nd some garbagde
some garbagde . some garbagde 2nd April some garbagde
some garbagde . some garbagde April 2nd some garbagde
some garbagde . some garbagde APR 12th some garbagde
some garbagde . April 12th some garbagde
some garbagde . 12th April some garbagde
some garbagde . April 13-16 some garbagde
some garbagde . 13-16 April some garbagde
some garbagde . APR 13-16 some garbagde
some garbagde . 13-16 APR some garbagde
some garbagde . April 13th-16th some garbagde
some garbagde . 13th-16th April some garbagde
some garbagde . APR 13th-16th some garbagde
some garbagde . 13th-16th APR some garbagde'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end