using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(([\W\w]*)(apps)(-?)([\w]{0,2})(.[\W\w]*))";
string input = @"notificationcentermainui.apps.homedepot.com";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}