$re = '/(([\W\w]*)(apps)(-?)([\w]{0,2})(.[\W\w]*))/';
$str = 'notificationcentermainui.apps.homedepot.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);