import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "url\\([\\.]{2}\\/(\\w+(([\\/]\\w+)*(-\\w+|\\.\\w+))*)";
final String string = "d: url(../images/printer.gif) top left no-repeat; {\n"
+ " .preview .mw-wiki-logo {\n"
+ " background-image: url(/static/images/project-logos/enwiki-1.5x.png); background-size: 135px auto background-image: url(/static/images/project-logos/enwiki-2x.png); \n"
+ ".preview li.mw-changeslist-line-watched, .preview li.mw-history-line-updated {\n"
+ " list-style-image: url(//upload.wikimedia.org/wikipedia/commons/1/19/ChangedBulletVector.svg);\n"
+ " list-style-image: url(//upload.wikimedia.org/wikipedia/commons/c/c2/ChangedBulletVector.png) \\9\n"
+ "}\n"
+ " }\n"
+ "}\n\n"
+ "@media (-webkit-min-device-pixel-ratio: 2),(min--moz-device-pixel-ratio: 2),(min-resolution: 2dppx),(min-resolution: 192dpi) {\n"
+ " .preview .mw-wiki-logo {\n"
+ " background-image: url(/static/images/project-logos/enwiki-2x.png);\n"
+ " background-size: 135px auto\n"
+ " }\n"
+ "}";
final String subst = "url(//en.wikipedia.org/${1})";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}