# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"url\([\.]{2}\/(\w+(([\/]\w+)*(-\w+|\.\w+))*)"
test_str = ("d: url(../images/printer.gif) top left no-repeat; {\n"
" .preview .mw-wiki-logo {\n"
" background-image: url(/static/images/project-logos/enwiki-1.5x.png); background-size: 135px auto background-image: url(/static/images/project-logos/enwiki-2x.png); \n"
".preview li.mw-changeslist-line-watched, .preview li.mw-history-line-updated {\n"
" list-style-image: url(//upload.wikimedia.org/wikipedia/commons/1/19/ChangedBulletVector.svg);\n"
" list-style-image: url(//upload.wikimedia.org/wikipedia/commons/c/c2/ChangedBulletVector.png) \\9\n"
"}\n"
" }\n"
"}\n\n"
"@media (-webkit-min-device-pixel-ratio: 2),(min--moz-device-pixel-ratio: 2),(min-resolution: 2dppx),(min-resolution: 192dpi) {\n"
" .preview .mw-wiki-logo {\n"
" background-image: url(/static/images/project-logos/enwiki-2x.png);\n"
" background-size: 135px auto\n"
" }\n"
"}")
subst = "url(//en.wikipedia.org/${1})"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.